专注于操作系统、网络、存储、安全、大数据与云计算、集群、基础组件等

脚踏实地的态度来总结所学所用,分享it技术文章

【实例】一个综合网络的搭建配置~

AR2220 加S5700 联通外网的例子,在S5700 下划分了三个vlan,vlan100 连接路由器,别的两个vlan 都可以访问外网,vlan 之间默认是互通的,就是把VLAN、静态路由、默认路由、NAT、ACL 综合了一下,遇到类似案例的朋友可以进行参考。

1

交换机配置

 

(1)VLAN 划分与接口加入

(2)VLAN 接口定义

(3)默认路由

(4)DHCP 配置

 

VLAN 配置与接口加入

[Huawei]vlan batch 2 4 6 8 100

[Huawei]interface giga 0/0/1

[Huawei-GigabitEthernet0/0/1]port link-type access

[Huawei-GigabitEthernet0/0/1]port default vlan 100

[Huawei]interface giga 0/0/3

[Huawei-GigabitEthernet0/0/3]port link-type access

[Huawei-GigabitEthernet0/0/3]port default vlan 2

[Huawei-GigabitEthernet0/0/3]

说明:由于5700 是不支持切换三层接口配置IP 地址的,所以只能以VLAN 接口的形式来连接路由器,VLAN 100 为连接路由器,而其余VLAN 则为接入用户的,这里只演示了VLAN 2。

VLAN 接口配置

[Huawei]interface vlanif 100

[Huawei-Vlanif100]ip address 1.1.1.2 255.255.255.0

[Huawei]interface vlanif 2

[Huawei-Vlanif2]ip address 192.168.2.1 255.255.255.0

说明:这里只创建了连接路由器的VLAN 接口以及接入VLAN2 的,其余的VLAN 接口配置类似。

默认路由配置

[Huawei]ip route-static 0.0.0.0 0.0.0.0 1.1.1.1

说明:因为5700 去往外网的数据包都交给路由器,所以只需要配置一条默认路由即可,其余内网访问都是通过本地路由表交换即可。

DHCP 配置(基于接口)

[Huawei]dhcp enable

[Huawei]int vlan 2

[Huawei-Vlanif2]dhcp select interface

[Huawei-Vlanif2]dhcp server dns-list 114.114.114.114

明:这里以VLAN2 下面的用户举例,其余的参数比如租期option 都在server 后面跟具体关键字即可。另外有的网络可能下面下接二层交换机,那么二层交换机与三层交换机之间的链路则配置为trunk,允许需要的VLAN 流量通过,记住华为的默认只允许VLAN 1

2

路由器配置

(1)静态/默认路由配置

(2)NAT 配置

《【实例】一个综合网络的搭建配置~》

 

[Huawei]interface giga 0/0/0

[Huawei-GigabitEthernet0/0/0]ip address 192.168.1.3 255.255.255.0

[Huawei]interface giga 0/0/1

[Huawei-GigabitEthernet0/0/1]ip address 1.1.1.1 255.255.255.0

静态与默认路由配置

[Huawei]ip route-static 192.168.0.0 255.255.0.0 1.1.1.2

[Huawei]ip route-static 0.0.0.0 0 192.168.1.111 (实际环境为ISP 的下一跳或者PPPOE 拨号接口)

说明:默认路由是为了去往访问公网的流量进行转发,而流量回来后需要知道怎么去往192.168.X.X 这个网络,保证能够正常的把数据包返回。

NAT 配置与ACL

[Huawei]acl number 2000

[Huawei-acl-basic-2000]rule 5 permit source 192.168.0.0 0.0.255.255

[Huawei]interface giga 0/0/0

[Huawei-GigabitEthernet0/0/0] nat outbound 2000

说明:这里是允许ACL 2000 内匹配的流量进行NAT 源转换,用G0/0/0 下的地址,保证能够访问公网。

优化下接用户的接口,可以选择把STP 关闭或者是开启边缘端口,加快STP 的收敛,不影响DHCP 地址的获取

[Huawei]interface g0/0/1

[Huawei-GigabitEthernet0/0/1]stp disable

或者

[Huawei]interface g0/0/1

[Huawei-GigabitEthernet0/0/1]stp edged-port enable

点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注